tfm apt-get dist-upgrade

Running a dist upgrade remotely via ssh on a system where i don’t have a kvm installed seems like a dangerous thing to do . But this test has to be done.

We are tacking about this:

348 upgraded, 9 newly installed, 8 replaced, 67 removed and 30 not upgraded.

What will happen ? Full list of the packages is this:

root@localhost: ~# apt-get dist-upgrade
Reading Package Lists… Done
Building Dependency Tree… Done
Calculating Upgrade… Done
The following packages will be upgraded
GeoIP (1.4.8-1tfm => 1.5.1-1tfm)
MySQL (5.6.10-2tfm => 5.6.13-1tfm)
MySQL-devel (5.6.10-2tfm => 5.6.13-1tfm)
MySQL-libs (5.6.10-2tfm => 5.6.13-1tfm)
MySQL-server (5.6.10-2tfm => 5.6.13-1tfm)
MySQL-test (5.6.10-2tfm => 5.6.13-1tfm)
alsa-firmware (1.0.25-1tfm => 1.0.27-1tfm)
alsa-lib (1.0.25-1tfm => 1.0.27-1tfm)
alsa-utils (1.0.25-2tfm => 1.0.27-1tfm)
apache2 (2.2.23-2tfm => 2.2.25-1tfm)
apache2-devel (2.2.23-2tfm => 2.2.25-1tfm)
apache2-manual (2.2.23-2tfm => 2.2.25-1tfm)
apache2-mod_ssl (2.2.23-2tfm => 2.2.25-1tfm)
apt (0.5.15lorg3.95-0.git416.9tfm => 0.5.15lorg3.95-0.git522.1tfm)
atk (2.3.3-1tfm => 2.8.0-1tfm)
bash (4.2.37-1tfm => 4.2.45-1tfm)
bind (9.9.2-1tfm => 9.9.3-2tfm)
bind-devel (9.9.2-1tfm => 9.9.3-2tfm)
bind-utils (9.9.2-1tfm => 9.9.3-2tfm)
binutils (2.22-5tfm => 2.23.2-2tfm)
busybox (1.20.2-1tfm => 1.21.1-1tfm)
cairo (1.10.2-1tfm => 1.12.14-2tfm)
cifs-utils (5.6-1tfm => 6.0-1tfm)
clamav (0.97.6-1tfm => 0.97.8-1tfm)
cmirror (2.02.98-5tfm => 2.02.98-6tfm)
corosync (2.1.0-1tfm => 2.3.0-1tfm)
corosynclib (2.1.0-1tfm => 2.3.0-1tfm)
corosynclib-devel (2.1.0-1tfm => 2.3.0-1tfm)
courier-imap (4.10.0-1tfm => 4.13-1tfm)
cracklib (2.8.18-1tfm => 2.8.22-1tfm)
cups (1.5.0-1tfm => 1.6.2-2tfm)
cups-devel (1.5.0-1tfm => 1.6.2-2tfm)
cups-libs (1.5.0-1tfm => 1.6.2-2tfm)
dbus (1.4.16-3tfm => 1.4.24-3tfm)
dbus-glib (0.98-1tfm => 0.100-1tfm)
device-mapper (1.02.63-5tfm => 1.02.63-6tfm)
device-mapper-devel (1.02.63-5tfm => 1.02.63-6tfm)
device-mapper-event (1.02.63-5tfm => 1.02.63-6tfm)
device-mapper-event-devel (1.02.63-5tfm => 1.02.63-6tfm)
device-mapper-event-libs (1.02.63-5tfm => 1.02.63-6tfm)
device-mapper-libs (1.02.63-5tfm => 1.02.63-6tfm)
dhclient (4.2.3P2-1tfm => 4.2.5P1-1tfm)
dhcp (4.2.3P2-1tfm => 4.2.5P1-1tfm)
dhcp-devel (4.2.3P2-1tfm => 4.2.5P1-1tfm)
diffutils (3.2-1tfm => 3.3-1tfm)
dmidecode (2.11-1tfm => 2.12-1tfm)
docbook-dtds (1.0-4tfm => 1.0-5tfm)
docbook-style-xsl (1.75.2-1tfm => 1.78.1-4tfm)
dos2unix (6.0.2-1tfm => 6.0.3-1tfm)
doxygen (1.7.6.1-1tfm => 1.8.3.1-1tfm)
drbd (8.3.13-1tfm => 8.4.3-1tfm)
drbd-bash-completion (8.3.13-1tfm => 8.4.3-1tfm)
drbd-heartbeat (8.3.13-1tfm => 8.4.3-1tfm)
drbd-pacemaker (8.3.13-1tfm => 8.4.3-1tfm)
e2fsprogs (1.42-1tfm => 1.42.7-1tfm)
elfutils (0.152-2tfm => 0.155-1tfm)
elfutils-devel (0.152-2tfm => 0.155-1tfm)
elfutils-libelf (0.152-2tfm => 0.155-1tfm)
elfutils-libelf-devel (0.152-2tfm => 0.155-1tfm)
elfutils-libs (0.152-2tfm => 0.155-1tfm)
elinks (0.11.7-2tfm => 0.12-pre6.2tfm)
ethtool (2.6.36-1tfm => 3.8-1tfm)
expat (2.0.1-2tfm => 2.1.0-1tfm)
fftw (3.3-1tfm => 3.3.3-1tfm)
file (5.09-1tfm => 5.14-1tfm)
flex (2.5.35-2tfm => 2.5.37-1tfm)
flex-devel (2.5.35-2tfm => 2.5.37-1tfm)
fontconfig (2.8.0-2tfm => 2.10.2-1tfm)
foomatic-db (4.0-20120213.1tfm => 4.0-20130417.1tfm)
freetype (2.4.8-1tfm => 2.4.11-1tfm)
freetype-devel (2.4.8-1tfm => 2.4.11-1tfm)
fribidi (0.19.2-1tfm => 0.19.5-1tfm)
fuse (2.9.2-1tfm => 2.9.3-1tfm)
fuse-libs (2.9.2-1tfm => 2.9.3-1tfm)
gcc (4.7.2-1tfm => 4.8.1-1tfm)
gcc-c++ (4.7.2-1tfm => 4.8.1-1tfm)
gcc-doc (4.7.2-1tfm => 4.8.1-1tfm)
gcc-python (4.7.2-1tfm => 4.8.1-1tfm)
gdb (7.3.1-1tfm => 7.5-1tfm)
genshi (0.6-1tfm => 0.7-1tfm)
gettext (0.18.1-1tfm => 0.18.2.1-1tfm)
git (1.8.0-1tfm => 1.8.2.1-2tfm)
gitweb (1.8.0-1tfm => 1.8.2.1-2tfm)
glibc (2.16.0-5tfm => 2.18-1tfm)
glibc-utils (2.16.0-5tfm => 2.18-1tfm)
gmp (5.0.5-1tfm => 5.1.1-1tfm)
gnutls (3.0.9-1tfm => 3.0.29-1tfm)
grep (2.9-1tfm => 2.14-1tfm)
groff-perl (1.21-3tfm => 1.22.2-1tfm)
groff-x11 (1.21-3tfm => 1.22.2-1tfm)
gtk2 (2.24.5-1tfm => 2.24.17-1tfm)
gtk2-devel (2.24.5-1tfm => 2.24.17-1tfm)
gzip (1.4-1tfm => 1.6-1tfm)
hdparm (9.28-1tfm => 9.32-1tfm)
hwdata (001-2tfm => 002-1tfm)
iotop (0.4.4-1tfm => 0.5-1tfm)
iproute (3.6.0-1tfm => 3.10.0-1tfm)
iptables (1.4.16.3-1tfm => 1.4.20-1tfm)
iputils (20101006-4tfm => 20121221-1tfm)
irqbalance (1.0.5-1tfm => 1.0.6-1tfm)
jemalloc (3.2.0-1tfm => 3.4.0-1tfm)
kernel (3.7.9-1tfm => 3.10.12-1tfm)
kernel-source (3.7.9-1tfm => 3.10.12-1tfm)
kmod (12-1tfm => 14-1tfm)
kmod-libs (12-1tfm => 14-1tfm)
krb5 (1.9.4-3tfm => 1.11.2-1tfm)
lemon (3.7.6.3-2tfm => 3.716.1-1tfm)
less (444-1tfm => 451-1tfm)
libassuan (2.0.3-1tfm => 2.1.0-1tfm)
libbluray (0.2.2-1tfm => 0.2.3-1tfm)
libcroco (0.6.4-2tfm => 0.6.8-1tfm)
libdc1394 (2.1.4-1tfm => 2.2.1-1tfm)
libdrm (2.4.39-1tfm => 2.4.44-1tfm)
libdvdcss (1.2.11-2tfm => 1.2.13-1tfm)
libebml (1.2.2-1tfm => 1.3.0-1tfm)
libestr (0.1.2-1tfm => 0.1.5-1tfm)
libev (4.04-1tfm => 4.15-1tfm)
libevent (2.0.17-1tfm => 2.0.21-1tfm)
libffi (3.0.11-2tfm => 3.0.13-1tfm)
libgcc (4.7.2-1tfm => 4.8.1-1tfm)
libgcrypt (1.5.0-1tfm => 1.5.2-1tfm)
libgpg-error (1.10-1tfm => 1.11-1tfm)
libidn (1.23-1tfm => 1.26-1tfm)
libjpeg-turbo (1.1.1-1tfm => 1.2.90-1tfm)
libjpeg-turbo-devel (1.1.1-1tfm => 1.2.90-1tfm)
libjpeg-turbo-static (1.1.1-1tfm => 1.2.90-1tfm)
libjpeg-turbo-utils (1.1.1-1tfm => 1.2.90-1tfm)
libksba (1.2.0-1tfm => 1.3.0-1tfm)
libmatroska (1.3.0-1tfm => 1.4.0-1tfm)
libmemcached (1.0.4-1tfm => 1.0.17-1tfm)
libnet (1.1.5-1tfm => 1.1.6-1tfm)
libnl (3.2.7-2tfm => 3.2.21-1tfm)
libpng (1.2.46-1tfm => 1.6.1-1tfm)
libqb (0.14.3-1tfm => 0.14.4-1tfm)
librsvg (2.34.2-2tfm => 2.36.4-1tfm)
libshout (2.2.2-1tfm => 2.3.1-1tfm)
libstdc++ (4.7.2-1tfm => 4.8.1-1tfm)
libtalloc (2.0.7-1tfm => 2.0.8-1tfm)
libtdb (1.2.9-1tfm => 1.2.11-1tfm)
libusb-compat (0.1.3-1tfm => 0.1.4-1tfm)
libusb1 (1.0.8-1tfm => 1.0.9-1tfm)
libva (1.1.0-1tfm => 1.1.1-1tfm)
libvorbis (1.3.2-1tfm => 1.3.3-1tfm)
libvpx (1.0.0-1tfm => 1.2.0-1tfm)
libxslt (1.1.26-1tfm => 1.1.28-1tfm)
libxslt-devel (1.1.26-1tfm => 1.1.28-1tfm)
libxslt-python (1.1.26-1tfm => 1.1.28-1tfm)
lilo (23.2-1tfm => 23.2-4tfm)
linux-firmware (20120925-0.1.git236367d.2tfm => 20130724-0.1.git31f6b30.1tfm)
lm_sensors (3.3.1-1tfm => 3.3.3-1tfm)
lm_sensors-devel (3.3.1-1tfm => 3.3.3-1tfm)
lm_sensors-libs (3.3.1-1tfm => 3.3.3-1tfm)
lm_sensors-sensord (3.3.1-1tfm => 3.3.3-1tfm)
logrotate (3.8.1-3tfm => 3.8.6-1tfm)
lsof (4.85-1tfm => 4.87-1tfm)
lvm2 (2.02.98-5tfm => 2.02.98-6tfm)
lvm2-cluster (2.02.98-5tfm => 2.02.98-6tfm)
lvm2-devel (2.02.98-5tfm => 2.02.98-6tfm)
lvm2-libs (2.02.98-5tfm => 2.02.98-6tfm)
man-pages (3.35-1tfm => 3.53-1tfm)
mdadm (3.2.3-1tfm => 3.2.6-1tfm)
microcode_ctl (2.0-1tfm => 2.1-2tfm)
minicom (2.6.1-1tfm => 2.6.2-1tfm)
mnogosearch (3.3.12-2tfm => 3.3.14-1tfm)
mod_dav_svn (1.7.7-2tfm => 1.7.11-1tfm)
mpfr (3.1.1-1tfm => 3.1.2-1tfm)
mtools (4.0.17-1tfm => 4.0.18-1tfm)
mtr (0.82-1tfm => 0.85-1tfm)
nasm (2.09.10-1tfm => 2.10.07-1tfm)
net-snmp (5.7.1-2tfm => 5.7.2-2tfm)
net-snmp-devel (5.7.1-2tfm => 5.7.2-2tfm)
net-tools (1.60-20120127git.1tfm => 2.0-20130109git.1tfm)
netpbm (10.57.01-1tfm => 10.61.02-1tfm)
netpbm-devel (10.57.01-1tfm => 10.61.02-1tfm)
nettle (2.4-1tfm => 2.6-1tfm)
nfs-utils (1.2.7-1tfm => 1.2.8-1tfm)
nmap-frontend (6.00-1tfm => 6.25-2tfm)
nspr (4.8.9-1tfm => 4.9.5-1tfm)
nss (3.13.1-1tfm => 3.14.3-1tfm)
nss-softokn (3.13.1-2tfm => 3.14.3-1tfm)
nss-softokn-freebl (3.13.1-2tfm => 3.14.3-1tfm)
nss-util (3.13.1-1tfm => 3.14.3-1tfm)
openhpi (2.17.0-1tfm => 3.2.0-1tfm)
openldap-clients (2.4.28-2tfm => 2.4.35-1tfm)
openldap-devel (2.4.28-2tfm => 2.4.35-1tfm)
openssh (6.1p1-1tfm => 6.2p2-1tfm)
openssh-clients (6.1p1-1tfm => 6.2p2-1tfm)
openssh-server (6.1p1-1tfm => 6.2p2-1tfm)
openssl (1.0.1-1tfm => 1.0.1e-1tfm)
openssl-devel (1.0.1-1tfm => 1.0.1e-1tfm)
openssl-doc (1.0.1-1tfm => 1.0.1e-1tfm)
openssl-libssl (1.0.1-1tfm => 1.0.1e-1tfm)
openswan (2.6.38-5tfm => 2.6.38-6tfm)
openvpn (2.2.2-1tfm => 2.3.1-1tfm)
pam (1.1.5-5tfm => 1.1.6-1tfm)
pam-devel (1.1.5-5tfm => 1.1.6-1tfm)
patch (2.6.1-1tfm => 2.7.1-1tfm)
pciutils (3.1.8-3tfm => 3.2.0-1tfm)
pcs (0.9.27-3tfm => 0.9.44-1tfm)
perl (5.14.2-6tfm => 5.14.4-7tfm)
perl-Archive-Extract (0.48-6tfm => 0.48-7tfm)
perl-Archive-Tar (1.76-6tfm => 1.76-7tfm)
perl-CGI (3.52-6tfm => 3.52-7tfm)
perl-CPAN (1.9600.01-6tfm => 1.9600.01-7tfm)
perl-CPAN-Meta (2.110440-6tfm => 2.110440-7tfm)
perl-CPAN-Meta-YAML (0.003-6tfm => 0.003-7tfm)
perl-CPANPLUS (0.91.3-6tfm => 0.91.3-7tfm)
perl-Carp (1.20-6tfm => 1.20-7tfm)
perl-Compress-Raw-Bzip2 (2.033-6tfm => 2.033-7tfm)
perl-Compress-Raw-Zlib (2.033-6tfm => 2.033-7tfm)
perl-Digest (1.16-6tfm => 1.16-7tfm)
perl-Digest-MD5 (2.51-6tfm => 2.51-7tfm)
perl-Digest-SHA (5.61-6tfm => 5.61-7tfm)
perl-ExtUtils-CBuilder (0.28.2.3-6tfm => 0.28.2.3-7tfm)
perl-ExtUtils-Embed (1.30-6tfm => 1.30-7tfm)
perl-ExtUtils-Install (1.56-6tfm => 1.56-7tfm)
perl-ExtUtils-MakeMaker (6.57.5-6tfm => 6.57.5-7tfm)
perl-ExtUtils-Manifest (1.58-6tfm => 1.58-7tfm)
perl-ExtUtils-ParseXS (2.2210-6tfm => 2.2210-7tfm)
perl-File-Fetch (0.32-6tfm => 0.32-7tfm)
perl-HTTP-Tiny (0.012-6tfm => 0.012-7tfm)
perl-IO-Compress (2.033-6tfm => 2.033-7tfm)
perl-IO-Zlib (1.10-6tfm => 1.10-7tfm)
perl-IPC-Cmd (0.70-6tfm => 0.70-7tfm)
perl-JSON-PP (2.27150-6tfm => 2.27150-7tfm)
perl-Locale-Codes (3.16-6tfm => 3.16-7tfm)
perl-Locale-Maketext-Simple (0.21-6tfm => 0.21-7tfm)
perl-Log-Message (0.04-6tfm => 0.04-7tfm)
perl-Log-Message-Simple (0.08-6tfm => 0.08-7tfm)
perl-Module-Build (0.3800-6tfm => 0.3800-7tfm)
perl-Module-CoreList (2.49-6tfm => 2.49-7tfm)
perl-Module-Load (0.18-6tfm => 0.18-7tfm)
perl-Module-Load-Conditional (0.44-6tfm => 0.44-7tfm)
perl-Module-Loaded (0.06-6tfm => 0.06-7tfm)
perl-Module-Metadata (1.000004-6tfm => 1.000004-7tfm)
perl-Module-Pluggable (3.90-6tfm => 3.90-7tfm)
perl-Object-Accessor (0.38-6tfm => 0.38-7tfm)
perl-Package-Constants (0.02-6tfm => 0.02-7tfm)
perl-Params-Check (0.28-6tfm => 0.28-7tfm)
perl-Parse-CPAN-Meta (1.4401-6tfm => 1.4401-7tfm)
perl-PathTools (3.33-6tfm => 3.33-7tfm)
perl-Perl-OSType (1.002-6tfm => 1.002-7tfm)
perl-Pod-Escapes (1.04-6tfm => 1.04-7tfm)
perl-Pod-Perldoc (3.15.04-6tfm => 3.15.04-7tfm)
perl-Pod-Simple (3.16-6tfm => 3.16-7tfm)
perl-Scalar-List-Utils (1.23-6tfm => 1.23-7tfm)
perl-Socket (1.94-6tfm => 1.94-7tfm)
perl-Term-UI (0.26-6tfm => 0.26-7tfm)
perl-Test-Harness (3.23-6tfm => 3.23-7tfm)
perl-Test-Simple (0.98-6tfm => 0.98-7tfm)
perl-Test-Simple-tests (0.98-6tfm => 0.98-7tfm)
perl-Time-Piece (1.20.1-6tfm => 1.20.1-7tfm)
perl-Version-Requirements (0.101020-6tfm => 0.101020-7tfm)
perl-XML-Parser (2.40-1tfm => 2.41-1tfm)
perl-core (5.14.2-6tfm => 5.14.4-7tfm)
perl-devel (5.14.2-6tfm => 5.14.4-7tfm)
perl-libs (5.14.2-6tfm => 5.14.4-7tfm)
perl-macros (5.14.2-6tfm => 5.14.4-7tfm)
perl-parent (0.225-6tfm => 0.225-7tfm)
perl-tests (5.14.2-6tfm => 5.14.4-7tfm)
perl-threads (1.83-6tfm => 1.83-7tfm)
perl-threads-shared (1.37-6tfm => 1.37-7tfm)
perl-version (0.88-6tfm => 0.88-7tfm)
perltidy (20101217-1tfm => 20121207-1tfm)
pixman (0.24.0-1tfm => 0.28.2-2tfm)
pkg-config (0.26-6tfm => 0.28-1tfm)
popt (1.13-3tfm => 1.13-4tfm)
popt-devel (1.13-3tfm => 1.13-4tfm)
popt-static (1.13-3tfm => 1.13-4tfm)
postgresql (8.4.10-3tfm => 8.4.17-1tfm)
postgresql-devel (8.4.10-3tfm => 8.4.17-1tfm)
postgresql-docs (8.4.10-3tfm => 8.4.17-1tfm)
ppl (0.11.2-1tfm => 1.0-1tfm)
ppp (2.4.5-4tfm => 2.4.5-6tfm)
psmisc (22.15-1tfm => 22.20-1tfm)
python (2.7.2-2tfm => 2.7.5-1tfm)
python-setuptools (0.6c11-1tfm => 0.9.8-1tfm)
qmail-scanner (2.10st-20111118.1tfm => 2.11st-20130319.1tfm)
quagga (0.99.20-1tfm => 0.99.22.4-1tfm)
quagga-contrib (0.99.20-1tfm => 0.99.22.4-1tfm)
quagga-devel (0.99.20-1tfm => 0.99.22.4-1tfm)
readline (6.2-3tfm => 6.2-4tfm)
redis (2.6.7-1tfm => 2.6.12-1tfm)
rp-pppoe (3.10-1tfm => 3.11-2tfm)
rpm (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-apidocs (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-build (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-build-libs (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-cron (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-devel (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-libs (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-python (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rpm-sign (4.9.1.3-2tfm => 4.10.3.1-2tfm)
rrdtool (1.4.7-1tfm => 1.4.8-1tfm)
rrdtool-perl (1.4.7-1tfm => 1.4.8-1tfm)
rrdtool-python (1.4.7-1tfm => 1.4.8-1tfm)
rrdtool-tcl (1.4.7-1tfm => 1.4.8-1tfm)
rsyslog (7.2.0-2tfm => 7.4.0-1tfm)
ruby (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-devel (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-irb (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-libs (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-rdoc (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-ri (1.9.3.392-2tfm => 1.9.3.448-3tfm)
ruby-static (1.9.3.392-2tfm => 1.9.3.448-3tfm)
samba (3.6.13-1tfm => 3.6.18-1tfm)
scons (2.2.0-11tfm => 2.3.0-11tfm)
sed (4.2.1-1tfm => 4.2.2-1tfm)
sgml-common (0.6.3-3tfm => 0.6.3-5tfm)
shadow (4.1.4.3-4tfm => 4.1.5.1-1tfm)
shared-mime-info (0.91-1tfm => 1.1-1tfm)
sharutils (4.6.2-1tfm => 4.13.5-1tfm)
smartmontools (5.42-1tfm => 6.1-1tfm)
sox (14.3.2-1tfm => 14.4.1-1tfm)
sqlite (3.7.6.3-2tfm => 3.716.1-1tfm)
sqlite-devel (3.7.6.3-2tfm => 3.716.1-1tfm)
sqlite-doc (3.7.6.3-2tfm => 3.716.1-1tfm)
squid (3.2.3-1tfm => 3.3.9-1tfm)
strace (4.6-1tfm => 4.7-1tfm)
strongswan (5.0.1-5tfm => 5.0.3-1tfm)
subversion (1.7.7-2tfm => 1.7.11-1tfm)
subversion-devel (1.7.7-2tfm => 1.7.11-1tfm)
subversion-perl (1.7.7-2tfm => 1.7.11-1tfm)
subversion-ruby (1.7.7-2tfm => 1.7.11-1tfm)
sudo (1.8.4p2-1tfm => 1.8.6p8-1tfm)
syslinux (4.04-1tfm => 5.01-1tfm)
sysstat (10.0.3-1tfm => 10.1.5-1tfm)
tcl (8.5.11-1tfm => 8.5.14-1tfm)
texinfo (4.13a-2tfm => 5.1-1tfm)
tfm-filesystem (34.0-8tfm => 34.0-10tfm)
tk (8.5.11-1tfm => 8.5.14-1tfm)
trac (0.12.4-1tfm => 1.0.1-1tfm)
traceroute (2.0.18-1tfm => 2.0.19-1tfm)
turbojpeg (1.1.1-1tfm => 1.2.90-1tfm)
turbojpeg-devel (1.1.1-1tfm => 1.2.90-1tfm)
tzdata (2012g-2tfm => 2013d-1tfm)
ucspi-tcp (0.88-4tfm => 0.88-5tfm)
usbutils (004-1tfm => 007-1tfm)
util-linux-ng (2.20-1tfm => 2.23.2-1tfm)
vo-aacenc (0.1.1-1tfm => 0.1.2-1tfm)
xfsprogs (3.1.8-1tfm => 3.1.11-1tfm)
xinetd (2.3.14-3tfm => 2.3.15-1tfm)
xml-common (0.6.3-3tfm => 0.6.3-5tfm)
xmlto (0.0.23-1tfm => 0.0.25-2tfm)
xz (5.0.3-1tfm => 5.0.5-1tfm)
xz-devel (5.0.3-1tfm => 5.0.5-1tfm)
xz-libs (5.0.3-1tfm => 5.0.5-1tfm)
xz-lzma-compat (5.0.3-1tfm => 5.0.5-1tfm)
The following packages will be REPLACED:
cloog-ppl (6.8.3.5-1tfm)
(by (4.11.1-1tfm)
cloog-isl) (0.15.11-1tfm)
(2.1.5-1tfm)
eject (4.0.8-1tfm)
(by (4.0.12-1tfm)
util-linux-ng) (2.2.0-2tfm)
(2.2.0-2tfm)
gettext-devel (2.2.0-2tfm)
(by (0.2.0-1.tfm)
gettext) (0.2.0-1.tfm)
(0.2.0-1.tfm)
gettext-devel-static (0.18.1-1tfm)
(by (0.18.1-1tfm)
gettext) (0.18.1-1tfm)
(0.18.1-1tfm)
gettext-doc (1.21-3tfm)
(by (4.11.1-1tfm)
gettext) (4.11.1-1tfm)
(4.11.1-1tfm)
gettext-doc-html (4.11.1-1tfm)
(by (4.11.1-1tfm)
gettext) (4.11.1-1tfm)
(4.11.1-1tfm)
procps (4.11.1-1tfm)
(by (4.11.1-2tfm)
procps-ng) (4.11.1-1tfm)
(4.11.1-1tfm)
qemu-kvm (4.11.1-1tfm)
(by (4.11.1-1tfm)
qemu) (6:4.11.1-1tfm)
The following packages will be REMOVED:
ImageMagick (6.8.3.5-1tfm)
ark (4.11.1-1tfm)
foomatic-db-engine (0.15.11-1tfm)
foomatic-filters (2.1.5-1tfm)
freeradius-dialupadmin (4.0.8-1tfm)
freeradius-dialupadmin-ldap (4.0.12-1tfm)
freeradius-dialupadmin-mysql (2.2.0-2tfm)
gegl (2.2.0-2tfm)
gegl-devel (2.2.0-2tfm)
gegl-operations-workshop (0.2.0-1.tfm)
groff (0.2.0-1.tfm)
kate (0.2.0-1.tfm)
kate-devel (0.18.1-1tfm)
kate-libs (0.18.1-1tfm)
kate-part (0.18.1-1tfm)
kde-base-artwork (0.18.1-1tfm)
kde-baseapps (1.21-3tfm)
kde-baseapps-devel (4.11.1-1tfm)
kde-baseapps-libs (4.11.1-1tfm)
kde-runtime-devel (4.11.1-1tfm)
kde-workspace (4.11.1-1tfm)
kde-workspace-devel (4.11.1-1tfm)
kde-workspace-ksplash-themes (4.11.1-1tfm)
kde-workspace-libs (4.11.1-1tfm)
kdelibs-devel (4.11.1-1tfm)
kdepim (4.11.1-2tfm)
kdepim-runtime (4.11.1-1tfm)
kdepim-runtime-libs (4.11.1-1tfm)
kdiff3 (4.11.1-1tfm)
kdm (4.11.1-1tfm)
kdm-themes (6:4.11.1-1tfm)
kgreeter-plugins (4.11.1-1tfm)
kmix (1:4.11.1-1)
konsole (1:4.11.1-1)
konsole-part (0.9.97-1tfm)
krdc (4.11.1-1tfm)
krdc-devel (4.11.1-1tfm)
krdc-libs (4.11.1-1tfm)
krename (4.11.1-1tfm)
krusader (4.11.1-1tfm)
ksnapshot (4.11.1-1tfm)
ktorrent (4.11.1-1tfm)
ktorrent-libs (4.11.1-1tfm)
kwallet (4.11.1-1tfm)
kwrite (4.0.9-1tfm)
libkcddb (2.4.0-1tfm)
libkgapi (4.10.2-1tfm)
libkgapi-devel (4.3.1-1tfm)
libkipi (4.3.1-1tfm)
libkipi-devel (4.11.1-1tfm)
libktorrent (4.11.1-1tfm)
libmongodb (4.11.1-1tfm)
libwebp-tools (2.0.1-1tfm)
mc (2.0.1-1tfm)
mongodb (4.10.2-1tfm)
mongodb-server (4.10.2-1tfm)
nepomuk-core-devel (1.3.1-1tfm)
nepomuk-widgets (2.2.2-1tfm)
netpbm-doc (0.3.1-1tfm)
netpbm-progs (4.8.10-1tfm)
php (2.2.2-1tfm)
php-fpm (2.2.2-1tfm)
plasma-scriptengine-python (4.11.1-1tfm)
plasma-scriptengine-ruby (4.11.1-1tfm)
qt-config (10.57.01-1tfm)
virtuoso-opensource (10.57.01-1tfm)
vlc (5.4.19-3tfm)
The following NEW packages will be installed:
cloog-isl (0.18.0-1tfm)
isl (0.11.2-2tfm)
liblognorm (0.3.5-2tfm)
libpng12 (1.2.50-6tfm)
libyaml (0.1.4-1tfm)
perl-Text-Unidecode (0.04-1tfm)
perl-libintl (1.20-1tfm)
procps-ng (3.3.7-1tfm)
qemu (1.6.0-2tfm)
The following packages have been kept back
OpenEXR (1.6.1-1tfm => 2.0.0-1tfm)
boost (1.50.0-1tfm => 1.53.0-3tfm)
ffmpeg (1.0-1tfm => 2.0.1-1tfm)
gdk-pixbuf2 (2.24.1-2tfm => 2.28.1-2tfm)
ghostscript (9.04-1tfm => 9.07-3tfm)
ghostscript-cups (9.04-1tfm => 9.07-3tfm)
ghostscript-devel (9.04-1tfm => 9.07-3tfm)
ghostscript-doc (9.04-1tfm => 9.07-3tfm)
ghostscript-gtk (9.04-1tfm => 9.07-3tfm)
git-arch (1.8.0-1tfm => 1.8.2.1-2tfm)
git-core (1.8.0-1tfm => 1.8.2.1-2tfm)
gitk (1.8.0-1tfm => 1.8.2.1-2tfm)
icu (49.1.1-1tfm => 50.1.2-1tfm)
ilmbase (1.0.1-2tfm => 2.0.0-1tfm)
lcms2 (2.3-1tfm => 2.4-2tfm)
libicu (49.1.1-1tfm => 50.1.2-1tfm)
libtiff (3.9.5-1tfm => 4.0.3-1tfm)
lighttpd (1.4.31-1tfm => 1.4.32-3tfm)
maildrop (2.5.5-1tfm => 2.6.0-2tfm)
mkvtoolnix (5.9.0-1tfm => 6.1.0-1tfm)
nginx (1.4.1-2tfm => 1.4.2-1tfm)
nmap (6.00-1tfm => 6.25-2tfm)
openjpeg (1.4-1tfm => 1.5.1-4tfm)
openldap (2.4.28-2tfm => 2.4.35-1tfm)
pcre (8.21-1tfm => 8.32-2tfm)
perl-Git (1.8.0-1tfm => 1.8.2.1-2tfm)
poppler (0.22.3-1tfm => 0.22.3-2tfm)
swig (2.0.4-1tfm => 2.0.9-1tfm)
wget (1.13.4-1tfm => 1.14-1tfm)
x264-snapshot (20121108.2245-1tfm => 20130903.2245-2tfm)
348 upgraded, 9 newly installed, 8 replaced, 67 removed and 30 not upgraded.
Need to get 1149MB of archives.
After unpacking 1029MB disk space will be freed.
Do you want to continue? [Y/n] y

This major change needed to be done because of the new pcre and since a hell lot of packages depends on it everything needed to be recompiled / updated .

After this i’ll have to:

  • recompile the whole KDE again
  • create some packages that will fake provide the things neeeded by Chrome
  • fix some of the kde packages ( i expect that not all of them will be nice and compile succesfully )
  • test / retest everything

And after this we can call the result : TFM Workstation 4.0 Alfa 1

 

What will happen after the dist-upgrade ? I have no idea . I’ll update this post after completion.

Later on:

Preparing                                ############################## [100%]
file /usr/bin/gtk-demo from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/bin/gtk-query-immodules-2.0 from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/bin/gtk-update-icon-cache from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-am-et.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-am-et.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-inuktitut.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-inuktitut.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ipa.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ipa.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-multipress.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-multipress.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-thai.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-thai.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/modules/libferret.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/gtk-2.0/modules/libgail.so from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/libgailutil.so.18.0.1 from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/libgdk-x11-2.0.so.0.2400.17 from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/libgtk-x11-2.0.so.0.2400.17 from install of gtk2-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gail.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gdk-2.0.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gdk-x11-2.0.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gtk+-2.0.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gtk+-unix-print-2.0.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/lib/pkgconfig/gtk+-x11-2.0.pc from install of gtk2-devel-2.24.17-1tfm.x86_64 conflicts with file from package gtk+-2.24.17-3tfm.x86_64
file /usr/share/man/man5/ldap.conf.5.gz from install of openldap-devel-2.4.35-1tfm.x86_64 conflicts with file from package openldap-2.4.28-2tfm.x86_64
file /usr/share/man/man5/ldif.5.gz from install of openldap-devel-2.4.35-1tfm.x86_64 conflicts with file from package openldap-2.4.28-2tfm.x86_64
E: Error while running transaction
E: Handler silently failed

 

 

 

 

 

3 thoughts on “tfm apt-get dist-upgrade

Comments are closed.